Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Apr 01, 2025 - 16:15 CEST
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Apr 01, 2025 - 15:15 CEST
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Apr 01, 2025 - 14:15 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 01, 2025 - 13:15 CEST
Scheduled
We are performing necessary maintenance work to ensure and further enhance the stability and performance of your services.
Despite our best efforts, brief service interruptions may occur during maintenance. We strive to keep any downtime as short as possible, typically lasting only a few seconds.
Posted Mar 24, 2025 - 14:00 CET
This scheduled maintenance affected: Shared Hosting (Web Services, Mail Services, Database Services, Backup Services) and Virtual Servers.